Differences between revisions 33 and 34
Revision 33 as of 2002-05-12 03:10:08
Size: 16655
Editor: 85-pool1
Comment:
Revision 34 as of 2002-05-12 03:10:56
Size: 16647
Editor: 85-pool1
Comment:
Deletions are marked like this. Additions are marked like this.
Line 212: Line 212:
[[BR]]

Comments on the Linksys WAP11 AccessPoint from the AccessPointReviews page.

  • Linksys Wireless Network Access Point WAP11 (24 April 2001)
  • Approximate Cost: $149 Buy.com, $179 from Best Buy after rebates, ibuyer.net ($235-$281)
  • OS Support: Windows 95, 98, 2000, NT, or ME (for configuration)
  • Protocol: 802.11b
  • Features:
    • Nics: 1 Wireless, 1 Ethernet
    • Antenna Connectors: 2 External Dipole Antennas, Removable, RP-TNC Female Jacks
    • Server Functions: None
    • Bridged Mode: Yes
    • Access Point Client Mode: Yes (with 1.4f5 firmware or newer)
    • Security: 40-bit WEP (128 bit with 1.4x firmware)
    • IP Address management: Manualy set or DHCP recipient
    • Power Source: 5 V, 2 Amp DC, Center-Positive on mini plug
  • Useful Links (Reviews, Product Description etc):
  • Comments/Thoughts:
    • New version of the firmware!
      • Wireless Bridging of physically separated LANs
      • MAC Address filtering
      • IP Filtering
      • SNMP Configuration Utility password protection
      • DHCP client
      • 128-bit WEP

      Unfortunately, I cannot get the new firmware to flash completely. It still functions to pass packets, but e.g. the SNMP manager cannot find it now. --[http://russnelson.com]

      • Note: 1.4h3 fiwmare requires 1.1 hardware to work properly. According to sources in the know, 1.0 hardware has a 2 megabit flash module, whereas 1.1 has a 4 megabit module. The 1.4h3 firmware has grown to large to fit in flash, and as a result the SNMP code portions won't run on 1.0 hardware. -- Xam R. Time
    • Cheap at $179 after rebates. This product is only a Wireless Ethernet Bridge. That's all, no NAT, no DHCP, no MAC filtering. Supports 40/64 bit WEP. Authentication Types are Open System, Shared Key, or both. Supports Short Preamble and Long Preamble. Basic Rates Include 1-2 Mbps, and 1-2-5.5-11 Mpbs, and Auto Rate Fall Back is a settable option. Fragmentation Threshold, and RTS Threshold are also settable. IP Settings are a bit screwed up. The wireless bridge comes with a static address and doesn't have the ability to use a DHCP server. Client machines attached to the wireless bridge can use DHCP fine though. Also Linksys says there is a bug in the IP settings that it doesn't allow the SNMP configuration utility to set two-digit IP addresses in the last two octets. Another bug is that with a Lucent Orinico card in W2K it reports an error message all the time that can be ignored. The latest version of the driver (Lucent's) is supposed to fix this. My biggest complaint, and the reason why I will be returning this product is that it doesn't have any password protection to the configuration. Anyone on your network that has downloaded the configuration program from Linksys's website can reconfigure your bridge at their will. Stupid. This product looks like it would be great for the Personal Telco project with the external detachable antennas, and cheap price, but it's fatal flaw is no password on the configuration. If Linksys fixes this in a future firmware release I would think about purchasing this product again. Until then it goes back to the store. -- TerrySchmidt

    Ours works fine, and when i forgot the password, it denied my access using the SNMP tool, i didn't test the usb tool. One thing though, is whatever firmware came right out of the box for us, doesn't actually allow me to change the channel. It's not really important, it's the only ap out there, but still... --ForrestEnglish

    • It is true that there is no password protection, but i do not believe it can be configured over wireless. It can be configured over usb with their "DFU" utility, or via wired ethernet with their SNMP program (both are windows only; there is no builtin http server as in the linksys switch/nat products). The wired side has a fixed ip address, default 192.168.1.250 (the wireless clients are bridged and get their own ip address, presumably through a dhcp server on the other side). So it is somewhat secure, since USB requires physical access, and the wired side requires private network access. But in larger companies, the private network has to be protected from employees. I had problems getting any settings to "stick", until i downloaded new firmware and the latest versions of the config software. Even with the the little antennas, my coverage has been the same as with an ad hoc network, but I do not have any other AP to compare it to. -- mda@discerning.com

    • The WAP11 Can be configured, using the SNMP Setup Utility, via wireless. A bit of a hole I would say... --John
    • I (JayPrimePositive) have had some troubles using snmpget/snmpset or the linksys-config from the Linux command line. Some Wap11 bugs sent its SNMP address to funny things (like 0.12.34.56) forcing me to use the USB Windows2000 configuration tool.

  • Great document by XamRTime of Wi2600 on how to make your Wap11 useful.
    • http://www.wi2600.org/mediawhore/nf0/wireless/docs/802.11/WAP11/fun_with_the_wap11.txt

    • As of current firmware (releases 1.4g5, 1.4g7, and 1.4g8, several things relating to SNMP configuration have been fixed by Atmel (the group actually writing the RTOS and doing the Acess Point code). On the top of the list are: removal of the ability to read WEP keystrings via. any SNMP community, community strings for read and read+write can be set durring initial setup via. the USB utility, or the SNMP utility, handling of multi-character IP address values works as it should, the WAP can allso be a DHCP recipient- with the wireless or wired interface being the prefered source, Access Point Client mode also now works- caveats: the access point client will (upon poweron) probe for a BSS to associate to; after hearing a reply from an AP in the BSS, it will complete it's association. However, when the AP-Client misses beacons or the AP it associated with gets reset/power cycled, the AP-Client will not reassociate. Very madening. Hopefully, this will get fixed soon. --Xam R. Time
    • A note about the utility; don't bother trying win95a/b (with the USB supplement), or win98 second edition; these platforms don't correctly load the USB driver for writing to the configuration registers in the WAP11. Windows 2000, 98 First Edition, and XP all correctly work with the wap11 via USB at the time of this writing. --Xam R. Time
    • I confirm that the USB utility will not work under Win98 2nd edition. The SNMP utility did work after I changed my 98s netmask :) Luckily I have v1.1 hardware. I am just trying to figure out how I am supposed to program the new firmware since hardware v1.1 still comes w/ flash v1.4i -- BambooLikeWater

    • A note about computers using DHCP and the Atmel utility; on WinNT4 (sp6a, all that jazz) simply installing the Atmel program, and then rebooting will result in DHCP services being broken. Even removing and reinstalling the network components will fail. you'l see a particularly bad result if you attemp to view bindings; it seems that something in the registry gets stompped on so badly that the network control applet crashes when trying to read bindings data. So, long and short: don't use DHCP on a NT4 box you wish to run the Atmel tool on. So far, no idea if this holds true on win2k. -- Xam R. Time
    • Some current bugs/badness:
      • If you're trying to set a fragment threshold below 256 bytes, you're in a rude trip with the WAP11. On 1.4g7 firmware, regardless of the bridging mode (bridge, AP, or AP-client), setting a frag-thresh below that somehow causes the bridge to freak out. SSID, IP address, and SNMP communities all fall back to defaults. -- Xam R. Time
      • You can, in fact, set a null SSID with the Atmel SNMP config tool (more info, and a download location are mentioned in the fun_with_the_wap11.txt). After setting a null sid and enabling AP-client mode, it seems the WAP11 won't associate to anything, leading me to beleive that the AP won't promiscuously latch onto a nearby network after seeing a broadcast SSID in a beacon. So, no war driving ala- ethernet bridge. --Xam R. Time
      • True access-point client (STAtion functionality, that is) mode would (you'd think) not require you to set a channel. However, for the WAP11 to do anything, you need to. This would logicaly impede having the WAP11 in AP client mode associate to more than one AP; you'd probably never have two within range of each other on the same channel, and would probably want to run non-overlaping AP's for backup or redundancy. I hope someone from Atmel or Linksys is reading this! AP-Client mode is nice, but it needs work! --Xam R. Time
      • It seems there is a split in hardware platforms emerging. Version 1.0 and 1.1 have now been seen in the market. What's the difference? A key change is that a 4 megabit flash module is now in the 1.1 hardware, whereas the 1.0 hardware only had 2 megabits of flash. Badness! Will they take back my older AP? Are they going to split the firmware families? - Xam R. Time
    • To change the output power without using the silly windows tools, snmpset 192.168.0.250 private .enterprises.410.1.1.8.8 x "80 80 80 80 80 80 80 80 80 80 80 80 80 80" you probably want to snmpget the default first though, as I believe the default is actually _calibrated_ per AP (to get them all to a uniform power level), and is probably designed to co-inside with the receive sensitivity somehow. I haven't needed to do this to my WAP11. --From HostAP mailing list


Please note that the 100mW hack for the LinksysWap11 is bad bad bad. CaseyHalverson has posted some notes on why [http://www.maokhian.com/wireless/wap11.html it's bad]. -- AdamShand

Also Ivan Korshun reports that it is possible to get signal strength from the Wap11's via SNMP if you are running firmware 1.4h3 (or later i presume). Details below ... -- AdamShand

If firmware 1.4h3 you can use OID: 1.3.6.1.4.1.410.1.2.7.1.0

  • {{{WLKnownAPGRP OBJECT IDENTIFIER ::= {wireless 7}

wirelessKnownAPsNum OBJECT-TYPE

  • SYNTAX INTEGER (1..8) ; ???? Wrong ACCESS read-only STATUS mandatory DESCRIPTION "." ::= {WLKnownAPGRP 1 }

}}}

For measure signal strength on a WAP11 in mode AP_client, using SNMPInquisitor.jar. In firmware 1.4h3 I have detected the following OIDs:

  • {{{1.3.6.1.4.1.410.x.x.x.x.x

1.1.1.1.0 1.1.1.2.0 1.1.1.3.0 1.1.1.4.0 1.1.1.5.0 1.1.1.6.0 1.1.2.1.0 1.1.2.2.0 1.1.2.3.0 1.1.2.4.0 1.1.2.5.0 1.1.2.6.0 1.1.3.1.0 1.1.4.1.0 1.1.4.2.0 1.1.7.1.0 1.1.7.2.0 1.1.8.1.0 1.1.8.2.0 1.1.8.8.0 1.1.8.9.0 1.1.9.1.0 1.1.9.2.0 1.1.9.3.0 1.2.1.1.0 1.2.1.2.0 1.2.1.3.0 1.2.1.4.0 1.2.1.5.0 1.2.1.6.0 1.2.1.7.0 1.2.1.8.0 1.2.1.9.0 1.2.1.10.0 1.2.1.11.0 !!! (SSID ENABLE_1 \ DISABLE_2 ) 1.2.1.12.0 !!! New, unknow 1.2.2.1.0 1.2.2.2.0 1.2.2.3.0 1.2.2.4.0 1.2.2.5.0 1.2.2.6.0 1.2.3.1.0 1.2.5.1.0 1.2.5.2.0 1.2.6.1.0 1.2.6.2.0 1.2.7.1.0 1.3.1.0.0 !!! unknow 1.2.2.2.2 !!! unknow 1.1.3.6.1 !!! unknow 1.1.0.9.0 !!! unknow}}}

Details OIDs the description in the file AT76C510.mib 30348 02.08.01 15:57 from new utilities WAP11.


A example MRTG setup for the Wap11 for more info see this [http://lists.bawug.org/pipermail/wireless/2002-February/005068.html thread].


I just bought a linksys wap11 ver 2.2 to replace my SMC AP I returned I think I will be returning it. It is not configured through SNMP, it uses HTTP, well this is good, cause I can just use netscape instead of finding a windows box to configure it. It supports up to 256 bit encryption. Too bad none of my pc cards support that. Anyway out of the box, it sets up easy. My big problem was the loss of signal compared to the SMC. The SMC has much further distance. My other problem is that my SMC pc card would not connect under WinXP, I ended up installing the linksys wpc11 driver, they are both prism2 chipset, while this worked fine it is by far the biggest drawback I found. I have a call into linksys to see if they can tell me why this is happening. I can't believe that the wap11 2.2 is vendor specific. I went to the linksys website and they had not one page covering the wap11 ver. 2.2. WTF way to sell a product, you don't even list at your website. The one bonus and the reason I purchased it was the removable antenna. Another problem I saw is the signal going up and down, at long distance it would lose link and get it back lose link and get it back, the link would be between 15 and 0. Lots of DUP! packets on pings also. I noticed a big improvment in signal by switching from diversity antenna to single antenna, right or left didn't seem to matter.

Oh yeah, and the box says "Free Technical Support--24 Hours a Day, 7 Days a Week, Toll-Free US Calls" LIES, LIES I TELL YOU. I thought cool I will call and see if they have a clue? Nowhere I repeat Nowhere did it have a phone number listed for the US, if I were in Japan I could call. I went to the website to get the US phone number, its 7-5 M-F. WTF LIES I SAY

M Lewis snoopy@penguinbait.com

I ran into a similar situation. I got a WAP11v2.2 for my birthday and (silly me) spent an hour or two trying to figure out how to flash the firmware, to no avail. I hit the website to digup the tech support number (did a search on google) and got through after a minute or two on Friday Night (6pm) from Alaska (10pm EST). They told me that there's no firmware upgrade. And as the box says 2002 all over it, I assume its just a new product. I'm using it with no problems with a D-Link 650.

jchandler jared@uaa.alaska.edu


Note that the ver2.2 WAP11 is completely different inside from the "old" WAP11. None of the flashing firmware, SNMP, other hacks from the old unit work with the new one. According to the documentation, the ver2.2 unit _will_ interoperate with the old design in the various bridging modes. The ver2.2 WAP11 comes in a blue and green cardboard box and is easy to identify if you have one in front of you. It claims 100mW RF output, which makes it hard to understand how range could be lower than any of the other low cost APs. Perhaps there are some bugs still to be worked out in this new design. I heard a rumor that it is based on euitcom technology (old WAP11 was Atmel). When I get a chance I will cut one open and take a look.

david_spam@boreham.org


I just bought two WAP11s (ver2.2) specifically for bridging... Tried to hook them up with no luck! Called tech support (it really is 24x7, I called at 12:30AM pacific time) and they said that the bridging is broke in this version (1.009). He said that a fix should be out in a few days. Today is 5/10/2002

I've heard so many good things about the WAP11 and I only paid $128/each from Newegg.com. I was bummed.

paul@vandyke.sytes.net

{{{From: M Henderson Subject: Re: Linksys WAP11 Ver. 2.2 power increase Newsgroups: alt.internet.wireless Date: 2002-04-29 19:28:28 PST

Noted someone had trouble getting the WAP11 to work in infrastructure mode. I had this problem and fought with it for a couple of hours.

When you change the settings, especially to settings other than Access Point you have to reset the device to get the settings to take full effect.

E.G. Change setting in web browser. Hit Apply Click on the return button then reset the device using the button on the back.

Also, this made no sense to me, but when linking to WAP11's in bridge mode you have to enter the MAC address of the device you are bridging to (point to point mode). OK that made sense, but you have to enter the MAC of the LAN side of the access point, not the wireless side.

Maybe someone else thinks thats intuitive, but from my point of view you are linking the wireless MAC's not the LAN.}}}


[CategoryDocumentation][CategoryHardware]

Wap11Comments (last edited 2007-11-23 18:01:46 by localhost)